Implement mitigation for GHSL-2021-045

Review Request #483 — Created Feb. 7, 2021 and submitted — Latest diff uploaded

grim
pidgin/pidgin
release-2.x.y
2b38057a835c
pidgin

This add a static inline version of g_memdup2 if the version of glib we're
compiling against doesn't have the function.

GHSL-2021-045 was originally reported to glib at
https://gitlab.gnome.org/GNOME/glib/-/issues/2319.

More information about the entire situation can be found on the gnome
desktop-devel-list at
https://mail.gnome.org/archives/desktop-devel-list/2021-February/msg00000.html

Compiled and ran tests locally.

Loading...